Перейти к содержимому


Фотография

Проблемы с диагностикой e39 1999г.в.


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 16

#1 BuTbka

BuTbka

    Пользователь

  • Пользователи
  • PipPip
  • 19 сообщений

Отправлено 08 сентября 2010 - 00:32

Недавно купил сканер inpa(не оригинал), крутил и так и так, пробовал подключать и через obd и через ads и настройки порта крутил, не подключается и все тут. Приехал к продавцу, он вынес свой ноут, на котором 100% рабочий софт стоит и еще 3 адаптера(один такойже, второй немного другой, но тоже inpa, третий inpa d-can). Результат тотже, правда удалось прочитать ошибки с коробки. DIS тоже не видит. Потом принес он carsoft 6.5, но и с ним ничего не вышло. Скажите в чем может быть причина? Куда копать?
P.S. Больно не бейте, опыта совсем мало.

#2 Lion

Lion

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 1 315 сообщений
  • ГородПитер

Отправлено 08 сентября 2010 - 03:07

Проверь диагностический провод. На днях была подобная машинка, там щиток полудохлый был.
Bm-multimedia.ru

#3 BuTbka

BuTbka

    Пользователь

  • Пользователи
  • PipPip
  • 19 сообщений

Отправлено 08 сентября 2010 - 10:58

Lion, спасибо! Только вот у меня два диагностических разъема OBD2 и ADS и с обоими такая ситуация. Подскажи пожалуйста где именно смотреть диагностический провод? В каком месте наиболее вероятна проблема?

#4 Lion

Lion

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 1 315 сообщений
  • ГородПитер

Отправлено 08 сентября 2010 - 11:27

Lion, спасибо! Только вот у меня два диагностических разъема OBD2 и ADS и с обоими такая ситуация. Подскажи пожалуйста где именно смотреть диагностический провод? В каком месте наиболее вероятна проблема?



Я бы посоветовал тебе обратиться к специалисту, а не самому искать. Судя по твоим вопросам ты ни чего об этом не знаешь.
Если все же хочешь сам, то открывай WDS смотри схемы. У тебя главный разъем это ADS, обд в твоем случае читает только мотор и коробку.
Bm-multimedia.ru

#5 BuTbka

BuTbka

    Пользователь

  • Пользователи
  • PipPip
  • 19 сообщений

Отправлено 08 сентября 2010 - 12:19

Lion, спасибо!

#6 BuTbka

BuTbka

    Пользователь

  • Пользователи
  • PipPip
  • 19 сообщений

Отправлено 09 сентября 2010 - 00:22

Частично разобрался. Сейчас пару часов просидел в машине с ноутом изучая мануалы по INPA. Получилось подключить только через OBD2 и запустить INP'у с настройками:
В файле c:\ediabas\bin\ediabas.ini
....
Interface=STD:OBD
....
а в файле c:\ediabas\bin\obd.ini(копия которого еще скопирована в c:\windows)
....
Hardware=USB
....
Как и говорил Lion, я смог увидеть только движок и коробку, остальные блоки не отвечают.
Теперь про мой комплект INPA, состоящий из 3х частей.
1. Адаптер с одной стороны OBD2, с другой RS232(Com)
2. Переходник usb<>rs232 на чипе Prolific PL2303
3. Переходник с OBD2 на ADS
вот с последним как раз и возникли трудности, т.е. через ADS связать не получается. Крутил выше указанные кофиги,
менял значения с USB на ADS и на OBD в файле c:\ediabas\bin\obd.ini и значения STD:OBD на ADS в файле c:\ediabas\bin\ediabas.ini, никакого положительного эффекта. Подскажите, может знает кто, как правильно сконфигурить INP'у для такого подключения?

#7 Lion

Lion

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 1 315 сообщений
  • ГородПитер

Отправлено 09 сентября 2010 - 00:41

Частично разобрался. Сейчас пару часов просидел в машине с ноутом изучая мануалы по INPA. Получилось подключить только через OBD2 и запустить INP'у с настройками:

В файле c:\ediabas\bin\ediabas.ini
....
Interface=STD:OBD
....
а в файле c:\ediabas\bin\obd.ini(копия которого еще скопирована в c:\windows)
....
Hardware=USB
....
Как и говорил Lion, я смог увидеть только движок и коробку, остальные блоки не отвечают.
Теперь про мой комплект INPA, состоящий из 3х частей.
1. Адаптер с одной стороны OBD2, с другой RS232(Com)
2. Переходник usb<>rs232 на чипе Prolific PL2303
3. Переходник с OBD2 на ADS
вот с последним как раз и возникли трудности, т.е. через ADS связать не получается. Крутил выше указанные кофиги,
менял значения с USB на ADS и на OBD в файле c:\ediabas\bin\obd.ini и значения STD:OBD на ADS в файле c:\ediabas\bin\ediabas.ini, никакого положительного эффекта. Подскажите, может знает кто, как правильно сконфигурить INP'у для такого подключения?


Не всякий ADS поддерживает переходник Com-USB. Для ADS нужен физический com1.
Твою машину можно прочитать и через ОБД, только переходник с ОБД на круглый разъем должен правильно распинован.
Bm-multimedia.ru

#8 BuTbka

BuTbka

    Пользователь

  • Пользователи
  • PipPip
  • 19 сообщений

Отправлено 09 сентября 2010 - 01:16

Lion, в комплекте шел и адаптер и переходник,думаю что они в комплект не стали бы класть то, что заведомо не будет совместимо. Хотя кто знает этих китайцев. Как проверить можно? Предполагаю что тестером прозвонить переходник - какая нога к какой идет с одной и с другой стороны.

Твою машину можно прочитать и через ОБД, только переходник с ОБД на круглый разъем должен правильно распинован.

Если правильно распинован, то какие настройки ставить, чтобы можно было прочитать? Теже?

#9 Lion

Lion

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 1 315 сообщений
  • ГородПитер

Отправлено 09 сентября 2010 - 01:22

Lion, в комплекте шел и адаптер и переходник,думаю что они в комплект не стали бы класть то, что заведомо не будет совместимо. Хотя кто знает этих китайцев. Как проверить можно? Предполагаю что тестером прозвонить переходник - какая нога к какой идет с одной и с другой стороны.

Твою машину можно прочитать и через ОБД, только переходник с ОБД на круглый разъем должен правильно распинован.

Если правильно распинован, то какие настройки ставить, чтобы можно было прочитать? Теже?


Настройки те же, как читал через обд.

У меня такая.
1 - 16
4/5 - 19
16 - 14
7 - 17
8 - 20
15 - 15
11 - 7
Bm-multimedia.ru

#10 BuTbka

BuTbka

    Пользователь

  • Пользователи
  • PipPip
  • 19 сообщений

Отправлено 09 сентября 2010 - 10:46

Lion
Кстати, при использовании через OBD2 разъем, INPA не видит ни зажигание, ни батарею.
Так и должно быть?

Проверил распиновку - первые 5 такиеже:
1 - 16
4/5 - 19
16 - 14
7 - 17
Потом
8 - 15
а остальных двух нет в разъеме OBD2 :(
Из-за этого наверное и не работает?
Где можно найти правильный переходник?

#11 BuTbka

BuTbka

    Пользователь

  • Пользователи
  • PipPip
  • 19 сообщений

Отправлено 14 сентября 2010 - 19:08

Ни чего не могу понять, сейчас и через OBD перестал читать.
Что может вызывать такое?

#12 Lion

Lion

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 1 315 сообщений
  • ГородПитер

Отправлено 14 сентября 2010 - 19:55

Ни чего не могу понять, сейчас и через OBD перестал читать.
Что может вызывать такое?


-Настройки
-адаптер
-собственная невнимательность
Bm-multimedia.ru

#13 BuTbka

BuTbka

    Пользователь

  • Пользователи
  • PipPip
  • 19 сообщений

Отправлено 14 сентября 2010 - 21:13

Как вот заработало, настройки потом не трогал. Может и в адаптере или переходнике com<>usb.
А из-за машины не может быть таких глюков?

#14 Lion

Lion

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 1 315 сообщений
  • ГородПитер

Отправлено 14 сентября 2010 - 21:27

Как вот заработало, настройки потом не трогал. Может и в адаптере или переходнике com<>usb.
А из-за машины не может быть таких глюков?



Может, попробуй почитать другую машину.
Bm-multimedia.ru

#15 BuTbka

BuTbka

    Пользователь

  • Пользователи
  • PipPip
  • 19 сообщений

Отправлено 15 сентября 2010 - 23:36

Пока другую машину нет возможности попробовать. И нет возможности попробовать подключить напрямую к COM порту. Но выявил интересную закономерность. Как только подключаю INP'у к любому разъему(либо OBD либо ADS), то могу читать и скидывать ошибки приблизительно в течение 2х минут, потом появляются ошибки связи. Если вытащить из разъема ADS(или OBD) и из USB ноута подождать минут 5-10, потом снова подключить, то опять все работает минуты 2 и потом снова появляются ошибки связи.

#16 BuTbka

BuTbka

    Пользователь

  • Пользователи
  • PipPip
  • 19 сообщений

Отправлено 19 сентября 2010 - 12:13

Попробовал прочитать другую машину - e46 через ADS, все работает отлично, без проблем. Значит у меня в машине какой-то косяк. Подскажите куда можно обратиться в Москве, не считая официалов.

#17 K13A

K13A

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 90 сообщений

Отправлено 19 ноября 2010 - 10:43

BuTbka, путаешь понятия разъема и протокола
ADS разъем - не значит ADS протокол
все 39/46 уже с протоколом OBD2
просто разъем не сразу OBD2 пошел
так что в конфиге INPA не надо переставлять режим в ADS для этих машин
хотя и по ADS они тоже будут читаться, смысла нет - медленне - это раз, да и адаптер врядли твой ADS поддерживает - это два )

ЗЫ тема видел, что сентябрьская, случайно наткнулся в поиске ))




Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных