Перейти к содержимому


Фотография

OPS & OPPS + Пакет (Inpa, Winkfp, Ediabas, NcsExpert)


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 87

#41 Кутузофф

Кутузофф

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 197 сообщений
  • ГородМосква

Отправлено 08 мая 2010 - 10:31

Можно вопрос - а почему тогда мехатроник по BMW-Fast не видится в кфп, а только через KWP2000? Если все одинаковое.....

#42 audivw

audivw

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 343 сообщений
  • ГородBelarus.Minsk.

Отправлено 08 мая 2010 - 15:05

Можно вопрос - а почему тогда мехатроник по BMW-Fast не видится в кфп, а только через KWP2000? Если все одинаковое.....

Кто сказал что он не видится? Видится. Процедуру одну проскочить не может на типовом - это да..
А идент и вообще все диагностические ветки - катят будь здоров.
Данные два пункта в хелпе едиабаса - подразумевают , что если вы будете пытаться D_12.grp, к примеру пытаться влезть в новый мотор - коннекта не будет, хотя бы по той простой причине что в 115200 бод этот grp канал не настраивает - хотя адресация верная. А если D_80.grp ломиться в новый щиток - то ко всему прочему, еще и не по адресу будет, поскольку адрес на щитках, с появлением новых кузовов сменился с 80 на 60.
Но если работать ИНПОЙ - то от таких ошибок, пользователь абстрагирован. И вникать в настройки канала и адресацию - ему совершенно ни к чему.

#43 Андрей

Андрей

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 141 сообщений
  • ГородУкраина

Отправлено 08 мая 2010 - 15:14

добавлю и я немного сравнений между оригиналом и китаем.

Китай не может работать в сети, по той простой причине, что в его МАС-адресе находятся одни нули, т.е. 00:00:00:00:00:00, в отличии от оригинала. Поэтому пока не будет там нормального адреса, сетевое подключение ему не светит, только прямое.
Если кто знает как эти нули можно поправить, буду рад услышать как делается или кто может это сделать.

Изображение

#44 audivw

audivw

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 343 сообщений
  • ГородBelarus.Minsk.

Отправлено 08 мая 2010 - 15:17

:shock: А что значит - прямое? Оно не сетевое?

#45 Андрей

Андрей

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 141 сообщений
  • ГородУкраина

Отправлено 08 мая 2010 - 18:03

:shock: А что значит - прямое? Оно не сетевое?


прямое, ну типа: OPS -> ноут/комп,
а сетевое: OPS - локальная сеть(свич) - ноут/комп

#46 Drive50

Drive50

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 46 сообщений
  • ГородМинск

Отправлено 08 мая 2010 - 18:16

добавлю и я немного сравнений между оригиналом и китаем.

Китай не может работать в сети, по той простой причине, что в его МАС-адресе находятся одни нули, т.е. 00:00:00:00:00:00, в отличии от оригинала. Поэтому пока не будет там нормального адреса, сетевое подключение ему не светит, только прямое.
Если кто знает как эти нули можно поправить, буду рад услышать как делается или кто может это сделать.

Извините Уважаемый, но я с Вами в корне не согласен!
Прекрасно работает в китае и сетевое подключение и прямое(причем кабель(перевертыш) не нужен, соеденяется любым)...
имхо: Настройки ediabas сделайте правильно и все будет ок.

#47 Андрей

Андрей

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 141 сообщений
  • ГородУкраина

Отправлено 08 мая 2010 - 18:24

добавлю и я немного сравнений между оригиналом и китаем.

Китай не может работать в сети, по той простой причине, что в его МАС-адресе находятся одни нули, т.е. 00:00:00:00:00:00, в отличии от оригинала. Поэтому пока не будет там нормального адреса, сетевое подключение ему не светит, только прямое.
Если кто знает как эти нули можно поправить, буду рад услышать как делается или кто может это сделать.

Извините Уважаемый, но я с Вами в корне не согласен!
Прекрасно работает в китае и сетевое подключение и прямое(причем кабель(перевертыш) не нужен, соеденяется любым)...
имхо: Настройки ediabas сделайте правильно и все будет ок.


я перепробовал все адаптеры которые были для соединения, при прямом подключении к GT1 или SSS, определяется сразу, при подключении к свичу - нет, оригинал без проблем определяется при любом подключении. Так что думаю проблема с МАК-адресом, сервер видать его отсекает. Даже при прямом подключении к SSS и внесения исправлений в конфигурацию OPS, сам SSS выдаёт ошибку что не может сконфигурировать интерфейс.

#48 Drive50

Drive50

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 46 сообщений
  • ГородМинск

Отправлено 08 мая 2010 - 18:36

добавлю и я немного сравнений между оригиналом и китаем.

Китай не может работать в сети, по той простой причине, что в его МАС-адресе находятся одни нули, т.е. 00:00:00:00:00:00, в отличии от оригинала. Поэтому пока не будет там нормального адреса, сетевое подключение ему не светит, только прямое.
Если кто знает как эти нули можно поправить, буду рад услышать как делается или кто может это сделать.

Извините Уважаемый, но я с Вами в корне не согласен!
Прекрасно работает в китае и сетевое подключение и прямое(причем кабель(перевертыш) не нужен, соеденяется любым)...
имхо: Настройки ediabas сделайте правильно и все будет ок.


я перепробовал все адаптеры которые были для соединения, при прямом подключении к GT1 или SSS, определяется сразу, при подключении к свичу - нет, оригинал без проблем определяется при любом подключении. Так что думаю проблема с МАК-адресом, сервер видать его отсекает. Даже при прямом подключении к SSS и внесения исправлений в конфигурацию OPS, сам SSS выдаёт ошибку что не может сконфигурировать прибор.

А при вводе адреса в эксплорере также через свитч но коннект?

#49 Андрей

Андрей

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 141 сообщений
  • ГородУкраина

Отправлено 08 мая 2010 - 18:44

добавлю и я немного сравнений между оригиналом и китаем.

Китай не может работать в сети, по той простой причине, что в его МАС-адресе находятся одни нули, т.е. 00:00:00:00:00:00, в отличии от оригинала. Поэтому пока не будет там нормального адреса, сетевое подключение ему не светит, только прямое.
Если кто знает как эти нули можно поправить, буду рад услышать как делается или кто может это сделать.

Извините Уважаемый, но я с Вами в корне не согласен!
Прекрасно работает в китае и сетевое подключение и прямое(причем кабель(перевертыш) не нужен, соеденяется любым)...
имхо: Настройки ediabas сделайте правильно и все будет ок.


я перепробовал все адаптеры которые были для соединения, при прямом подключении к GT1 или SSS, определяется сразу, при подключении к свичу - нет, оригинал без проблем определяется при любом подключении. Так что думаю проблема с МАК-адресом, сервер видать его отсекает. Даже при прямом подключении к SSS и внесения исправлений в конфигурацию OPS, сам SSS выдаёт ошибку что не может сконфигурировать прибор.

А при вводе адреса в эксплорере также через свитч но коннект?


к сожалению да, проверял ноутом, который был подключен в этот же свич :(

#50 Drive50

Drive50

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 46 сообщений
  • ГородМинск

Отправлено 08 мая 2010 - 18:47

к сожалению да, проверял ноутом, который был подключен в этот же свич :(

Адрес у компа статический или авто?

#51 Drive50

Drive50

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 46 сообщений
  • ГородМинск

Отправлено 08 мая 2010 - 18:49

:shock: А что значит - прямое? Оно не сетевое?


Рад видеть Вас и на этом форуме. Однако логотипчик не тот...

#52 Андрей

Андрей

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 141 сообщений
  • ГородУкраина

Отправлено 08 мая 2010 - 19:16


к сожалению да, проверял ноутом, который был подключен в этот же свич :(

Адрес у компа статический или авто?


у ноута авто, т.е. он автоматом получает настройки сети, а SSS, GT1 и OPSы имеют постоянные адреса, которые в них прописаны.

#53 Drive50

Drive50

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 46 сообщений
  • ГородМинск

Отправлено 08 мая 2010 - 19:24


к сожалению да, проверял ноутом, который был подключен в этот же свич :(

Адрес у компа статический или авто?


у ноута авто, т.е. он автоматом получает настройки сети, а SSS, GT1 и OPSы имеют постоянные адреса, которые в них прописаны.

От кого ноут кроме самого себя может получать настройки? или роут в сети имеется? хр стоит насколько я понимаю.
Поставь ноуту вручную. 192.168.68.хх. И попробуй эксплорером адрес головы(со свичем)

#54 Андрей

Андрей

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 141 сообщений
  • ГородУкраина

Отправлено 08 мая 2010 - 19:44


к сожалению да, проверял ноутом, который был подключен в этот же свич :(

Адрес у компа статический или авто?


у ноута авто, т.е. он автоматом получает настройки сети, а SSS, GT1 и OPSы имеют постоянные адреса, которые в них прописаны.

От кого ноут кроме самого себя может получать настройки? или роут в сети имеется? хр стоит насколько я понимаю.
Поставь ноуту вручную. 192.168.68.хх. И попробуй эксплорером адрес головы(со свичем)


1) ноут получает адреса от сервера по DHCP, т.к. он их задаёт
2) а причём тут 192.168.68.хх, если у меня адресация сетки 192.168.5.хх? + ОПС уже перестроен под локальную сеть

вот настройки уже китайца

Изображение

#55 Drive50

Drive50

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 46 сообщений
  • ГородМинск

Отправлено 08 мая 2010 - 19:47

1) ноут получает адреса от сервера по DHCP, т.к. он их задаёт
2) причём тут 192.168.68.хх, если у меня адресация сетки 192.168.5.хх? + ОПС уже перестроен под локальную сеть

А у головы какой адрес? (сори не посмотрел)

ОПС уже перестроен под локальную сеть

А SSS тоже перестроен?

имхо: Я бы убрал все твои dhcp. Проверил как работет в родном диапазоне(192.168.68.хх через свитч ли хаб) со стат адресами, а потом уже настраивал все твои премудрости.

#56 Андрей

Андрей

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 141 сообщений
  • ГородУкраина

Отправлено 08 мая 2010 - 19:51

А у головы какой адрес?


смотрите картинку :wall:

192.168.5.154

#57 audivw

audivw

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 343 сообщений
  • ГородBelarus.Minsk.

Отправлено 08 мая 2010 - 23:51

Много нового узнал о TCP\IP, читая тему :) Непостижимым образом вы намешали в одну кучу три слоя, так называемой семиуровневой модели OSI . :)
Пустой мак (00 00 00 00 00 00 ) , вообще то с точки зрения логики, должен полноценно восприниматься как мак...пусть и с нулевыми байтами. Но не исключаю, что производители различных свичей, при программировании своих устройств, такие маки видят исключением (Вся транспортная организация в свичах - основана как раз на МАК адресах)
Китайские сетевухи для IBM архитектуры - часто имеют один МАК на всю партию (такое производство, понимаешь ли... :D ) .Так что ничего удивительного - если и совсем забудут МАК записать :D

#58 ivx

ivx

    Пользователь

  • Пользователи
  • PipPip
  • 25 сообщений

Отправлено 09 мая 2010 - 16:03

У тебя же написано, что не хватает групового файла, ищи более свежие!

Где такое написано?


Читаем мануал по Ediabas и думаем что не так

IFH-0009: NO RESPONSE FROM CONTROLUNIT EDIABAS_IFH_0009
Meaning: The ECU is not connected or does not respond.
Causes: The ECU is not connected (or not properly).
The ECU is not supplied with voltage.
The ECU is addressed with a wrong address.
The ECU parameters are incorrect (concept, times, etc.).

Error correction: Check the error causes above.
Target system: WIN SCO

Выделенные ошибки также получаются когда в описании нет информации о блоках, данные в блоке запросто могут быть новее чем в программе и соответственно не давать ответа... Именно поэтому и стоит попробовать подсунуть свежие данные, прежде чем ломать что то ))


С появлением BMW-fast, как вариации KWP-2000 и следовательно своим набором grp файлов - ни один модуль не поменял ни своей адресации , ни "настроек" на обмен. Ваш ответ неверен.
В данном случае - просто нет ответа от модулей. Причина - или адаптер, или коммуникация.

По подробнее можно где что в адаптере смотреть и коммуникации :pardon: какие варианты решения данной проблемы....

#59 audivw

audivw

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 343 сообщений
  • ГородBelarus.Minsk.

Отправлено 09 мая 2010 - 21:45

А как можно подробней, даже не зная и не видя, чем и как вы коннектите компьютер к автомобилю?

#60 ivx

ivx

    Пользователь

  • Пользователи
  • PipPip
  • 25 сообщений

Отправлено 10 мая 2010 - 00:07

Inpa выдает "IFH-0009: No response from control unit" проблема в настройке Inpa или в OPS ? ps; на машинах с D-CAN

А как можно подробней, даже не зная и не видя, чем и как вы коннектите компьютер к автомобилю?

я указывал выше :drinks:
Коннект через OPS (в EasyKFP Remote 192.168.68.85 ) голову лочу
Проблема только с машинами с DCAN ... батарея и игнатион загораеться Inpa выдает "IFH-0009: No response from control unit" :hi:




Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных