Перейти к содержимому


Фотография

BMW X5 E53 Кодирование парктроника


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 19

#1 Nedovolen

Nedovolen

    Новичок

  • Пользователи
  • Pip
  • 8 сообщений

Отправлено 08 июня 2015 - 18:13

Здравствуйте. Автомобиль е53 2000 г. Чтобы сэкономить на 4 передних датчиках PDC (да и не нужен мне передний вообще) решил программно отключить передний парктроник. Кодирую через .man, создал в папке work пустой файл, выбрал блок PDC, жму "читать", ругается на отсутствие файла nettodat.trc. Создал такой пустой. После чтения блока открывается этот пустой nettodat и в папке work создается пустой fsw_psw.trc. При попытке прочитать через F5 - coapiReadSgGetFswPsw ругается на COAPI-1000: error. Профили настраивал по-разному, пробовал читать другие блоки - с другими работает! Где-то читал что некоторые парктроники не кодируются, это правда? Неужели нет выхода кроме всех 8 рабочих датчиков?



#2 NUFLIN

NUFLIN

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 1 552 сообщений
  • ГородМосква

Отправлено 08 июня 2015 - 20:50

Nedovolen,
ЗАЧЕМ удалять гланды через анус? - все банально, процедура занимает пару минут с перекуром... забудь про "пустой ман", почитай инструкции и изучи FSW/PSW...

Если ни о чем не думать и ничего не делать - не совершишь ошибок: "Мертвые не потеют" :ugeek:


#3 neo67

neo67

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 276 сообщений
  • ГородСмоленск

Отправлено 08 июня 2015 - 20:52

тупо считай кодировки блока--если там пусто то да...есть такие блоки где ничего не изменишь. как раз в твоем случае похоже на это.


сознание человека поднимается или опускается до уровня его окружения

#4 Nedovolen

Nedovolen

    Новичок

  • Пользователи
  • Pip
  • 8 сообщений

Отправлено 08 июня 2015 - 20:59

Nedovolen,
ЗАЧЕМ удалять гланды через анус? - все банально, процедура занимает пару минут с перекуром... забудь про "пустой ман", почитай инструкции и изучи FSW/PSW...

Ничего не понял. Я что-то делал не так?



#5 Nedovolen

Nedovolen

    Новичок

  • Пользователи
  • Pip
  • 8 сообщений

Отправлено 08 июня 2015 - 21:35

похоже, вот такая же проблема http://bmwpost.ru/fo...a-chtoli-29486/

 

скачал приложенные файлы, попробую



#6 Zheka1983

Zheka1983

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 419 сообщений

Отправлено 09 июня 2015 - 10:54

 Неужели нет выхода кроме всех 8 рабочих датчиков?

 

Есть блоки для 4х датчиков - цена на Б/У сравнима с ценой одного нового датчика.



#7 Nedovolen

Nedovolen

    Новичок

  • Пользователи
  • Pip
  • 8 сообщений

Отправлено 09 июня 2015 - 12:58

спасибо пытавшимся помочь. проблема решилась заменой файла PDC.C00



#8 Zheka1983

Zheka1983

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 419 сообщений

Отправлено 09 июня 2015 - 15:08

Заменой где ? Обновлял ПО ? 



#9 ми)(алыч

ми)(алыч

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 232 сообщений
  • ГородВладимир

Отправлено 09 июня 2015 - 17:04

спасибо пытавшимся помочь. проблема решилась заменой файла PDC.C00

Надеюсь не корректно запостил..... Какой номерок прошивки лил и какой уровень интеграции теперь? Интересно,стало ,потому что вспомнил много лет назад не справился с такой задачей



#10 Nedovolen

Nedovolen

    Новичок

  • Пользователи
  • Pip
  • 8 сообщений

Отправлено 09 июня 2015 - 20:27

Скачал по ссылке выше файл PDC.C00, заменил аналогичный в NCSEXPER/DATEN/E53, после этого блок прочитался, поменял 8wandler на 4wandler, залил обратно используя CVT. Сейчас только парктроник работает после кодировки как нужно, но до первого выключения зажигания. После включения зажигания не реагирует ни на кнопку, ни на задний ход, датчики при этом трещат. Пытаюсь в данный момент побороть.



#11 Nedovolen

Nedovolen

    Новичок

  • Пользователи
  • Pip
  • 8 сообщений

Отправлено 09 июня 2015 - 21:11

 

спасибо пытавшимся помочь. проблема решилась заменой файла PDC.C00

Какой номерок прошивки лил и какой уровень интеграции теперь? 

 

 

я не знаю, что это такое :mellow:



#12 ми)(алыч

ми)(алыч

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 232 сообщений
  • ГородВладимир

Отправлено 09 июня 2015 - 23:26

 

 

спасибо пытавшимся помочь. проблема решилась заменой файла PDC.C00

Какой номерок прошивки лил и какой уровень интеграции теперь? 

 

 

я не знаю, что это такое :mellow:

 

C00 это кодировочный индекс или уровень интеграции. Мне как раз попался такой и при прочтении ТРЦ был пустой. Сколько я ни пытался прилить его,ни одной прошивки он не принял.,даже пытался ручками вбить параметры. Вообщем я забил,решив что 00 это железка с неизменяемым софтом или что то подобное. Поэтому меня и заитересовал твой пост.



#13 Anton525IA

Anton525IA

    Новичок

  • Пользователи
  • Pip
  • 2 сообщений

Отправлено 13 августа 2015 - 23:45

Скачал по ссылке выше файл PDC.C00, заменил аналогичный в NCSEXPER/DATEN/E53, после этого блок прочитался, поменял 8wandler на 4wandler, залил обратно используя CVT. Сейчас только парктроник работает после кодировки как нужно, но до первого выключения зажигания. После включения зажигания не реагирует ни на кнопку, ни на задний ход, датчики при этом трещат. Пытаюсь в данный момент побороть.



#14 Anton525IA

Anton525IA

    Новичок

  • Пользователи
  • Pip
  • 2 сообщений

Отправлено 13 августа 2015 - 23:46

Так как успехи?то же самое твориться, только с двумя блока и 00 и 03

#15 NUFLIN

NUFLIN

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 1 552 сообщений
  • ГородМосква

Отправлено 14 августа 2015 - 02:55

Так как успехи?то же самое твориться, только с двумя блока и 00 и 03

 

Какие могут быть "успехи" у человека, не понимающего, ЧТО он делает, и ДЛЯ ЧЕГО... давай хоть ты разберись в проблеме, благо информации "выше крыши"...


Если ни о чем не думать и ничего не делать - не совершишь ошибок: "Мертвые не потеют" :ugeek:


#16 Nedovolen

Nedovolen

    Новичок

  • Пользователи
  • Pip
  • 8 сообщений

Отправлено 27 октября 2015 - 15:39

Жаль, что на каждом форуме полно мудрецов, которые слишком умны, чтобы делиться опытом с остальными. Если кому-то будет интересно или кто-то столкнется с такой же проблемой, то вот решение. Сначала блок pdc вообще не кодировался. Открыл файл pdc.c00 через bmw coding tool. Программа на него ругнулась и предложила пересобрать. Согласился. После этого блок закодировался, но, как я уже писал, парктроник работал до первого выключения зажигания. С этим бился больше всего времени, поэтому и просил совета. "Продвинутые пользователи" ничего посоветовать не смогли, экспериментировал сам. Оказалось, проблема в одном из датчиков парктроника, он не работал. Поэтому после кодирования некорректно работал. Устранил проблему с датчиком, закодировал блок последний раз и теперь уже несколько месяцев у меня только задний парктроник. Все мои действия были изначально правильны, просто не знал про такой эффект от сочетания неисправного датчика и кодирования блока. Всем спасибо, как говорится.



#17 Knyaz721

Knyaz721

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 1 226 сообщений
  • ГородСочи

Отправлено 27 октября 2015 - 18:32

А что ошибок в блоке не было?
Чем больше я узнаю, тем больше я понимаю, на сколько мало я знаю.

#18 NUFLIN

NUFLIN

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 1 552 сообщений
  • ГородМосква

Отправлено 28 октября 2015 - 00:43

А что ошибок в блоке не было?

 

Вопрос стоял именно в том, чтобы правильно интерпретировать буковки, которые программа пишет... из-за неспособности ТС это выполнить и появилось почти два десятка постов в теме, в результате - ТС один Д*артаньян, все остальные должны срочно посыпать головы пеплом... :hahaha: и учиться гланды через анус удалять по его рецепту (прямо говоря, ОЧЕНЬ корявому).


Если ни о чем не думать и ничего не делать - не совершишь ошибок: "Мертвые не потеют" :ugeek:


#19 Lehrling

Lehrling

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 336 сообщений
  • ГородС

Отправлено 28 октября 2015 - 01:26

ну откуда же ТС знал, что не работает один парк - не работает система в целом?



#20 Nedovolen

Nedovolen

    Новичок

  • Пользователи
  • Pip
  • 8 сообщений

Отправлено 28 октября 2015 - 09:40

Жаль, что местные умы еще и невнимательно читают посты. Я говорил, что блок был закодирован при неработающем датчике (проблема была в разъеме) и после кодирования ошибки не было. Все 4 датчика трещали, выяснить, что проблема в одном из них удалось, посмотрев в инпе сигнал от каждого. Вывод: кодировать надо, когда все датчики заведомо исправны, этого ТС действительно не знал. Тему можно закрывать :)






Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных