Перейти к содержимому


Фотография

BMW X5 E70 2008 К-CAN


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 12

#1 mcroff

mcroff

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 47 сообщений

Отправлено 17 января 2014 - 13:19

Е70 2008 в блоках некоторых сидит ошибка по ло кан и шина иногда ведёт себя "замороженно"(медиа отключается с задержкой, сканнер инпа+опс видит при

чтении ошибок всякий раз разное кол-во блоков и тд.) Отключчил всё от шины посмотрел на замыкание всё нормально.Подключил кас и жбе связь стабильная.

Начинаю добовлять при подключении джойстика шина падает,подкидываю другой рабочий та же история. Если оставить джойстик и добавить камфорт доступ

и парктронник связь восстонавливается. Если полностью подключить всё оборудование опять начинается нестабильная работа. Проблема совпала с просадкой.

Три месяца назад  делалось дооснощение лед фары +циц. Кан фильтр отключён. Может ли быть проблема в софте? Есть ли у к кана возможность (необходимость)

кофигурировать участников шины.



#2 MEN

MEN

    Администратор

  • Администраторы
  • 1 394 сообщений
  • ГородМинск BY

Отправлено 17 января 2014 - 16:48

Возможно где-то прогнило отвалилось



#3 mcroff

mcroff

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 47 сообщений

Отправлено 17 января 2014 - 17:52

Да вроде звонится всё. Я так понимаю софт здесь ни причём? Могут ли другие шины через жбе сажать?



#4 2real4u

2real4u

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 799 сообщений
  • ГородЧикаго

Отправлено 17 января 2014 - 20:43

наверно стоит посмотреть на K-CAN HI и KCAN LOW на осциллографе или логическом анализаторе, подключая и отключая блоки. K-CAN - это fault-tolerant can, она умеет работать по одному проводу если второй разорван, замкнут на землю или на питание. но для этого функционала этот режим должны поддерживать все блоки. может еще что-то не родное висит на шине? по стандарту CAN если блок не слышит ответа (ACK) на шине, он начинает непрерывно повторять последнее сообщение, 'вешая' шину для всех остальных. такое возможно если на неисправной K-CAN висит блок который не умеет общаться по протоколу fault-tolerant



#5 pepelxl

pepelxl

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 141 сообщений

Отправлено 17 января 2014 - 21:49

Если при подключении заведомо исправного джойстика всё равно появляются ошибки – значит сгнила проводка. На семидесятке гниёт , обычно, в двух местах – скрутки в багажнике справа и в пороге заднем правом.



#6 mcroff

mcroff

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 47 сообщений

Отправлено 17 января 2014 - 22:07

Блоки весят родные я думаю протоколы которые нужны присутствуют.

А вот насчёт не получения ответа это интересно. Какие могут быть причины сего поведения?

Скрутки в багажнике были некрасивые, но на работоспособность не повлияли.

В пороге не смотрел пока но посмотрю, спасибо.



#7 2real4u

2real4u

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 799 сообщений
  • ГородЧикаго

Отправлено 17 января 2014 - 22:40

А вот насчёт не получения ответа это интересно. Какие могут быть причины сего поведения?

пример - смерть трансивера CAN - когда контроллер отправляет сообщение, трансивер посылает его на провода CAN, но ответ (ACK) до контроллера не доходит например из-за неисправности трансивера или повреждения дорожки R на плате от трансивера до контроллера



#8 mcroff

mcroff

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 47 сообщений

Отправлено 17 января 2014 - 23:19

Насколько я понял при таких проблемах софт ни причём скорее всего железо.

Единствено непонятно почему при подсоединении трёх эбу всё работает а если один или два

исключить шина висит.



#9 fay

fay

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 32 сообщений
  • ГородМосква

Отправлено 17 января 2014 - 23:44

Насколько я понял при таких проблемах софт ни причём скорее всего железо.

Единствено непонятно почему при подсоединении трёх эбу всё работает а если один или два

исключить шина висит.

Подыми ковры передние посмотри есть водичка?



#10 mcroff

mcroff

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 47 сообщений

Отправлено 17 января 2014 - 23:54

Ок. Буду ещё раз шерстить железо.



#11 sergant

sergant

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 266 сообщений
  • ГородСаратов

Отправлено 19 января 2014 - 11:30

Проверь для начала провода can.

В 80% случаев на Е70 зеленеет и отваливаются провода CAN в скрутке в багажнике справа внизу под предохранителями в жгуте проводов.(провода могут звониться)

Так же такуюже проблему находил пару раз над тонелем под понелью(тяжело долезть) 


  • zaharich это нравится

#12 mcroff

mcroff

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 47 сообщений

Отправлено 20 января 2014 - 22:40

Да действительно была зелень, правда зелень на прямом участке в пороге(скрутки окозались целыми).

Похоже изоляцию поведили ну а дальше время.

Всем спасибо.



#13 kaa

kaa

    Пользователь

  • Пользователи
  • PipPip
  • 12 сообщений
  • ГородСаратов

Отправлено 28 июня 2014 - 01:36

На е70 трубка омывателя заднего стекла, болезнь у них.






Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных